解决IE兼容问题

杂七杂八 4470 Views 0 Comments

让IE用上Chrome的引擎:
<meta http-equiv="X-UA-Compatible" content="chrome=1" />

强制IE8使用IE7模式来解析:
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"><!-- IE7 mode -->
或者
<meta http-equiv="X-UA-Compatible" content="IE=7"><!-- IE7 mode -->

强制IE8使用IE6或IE5模式来解析:
<meta http-equiv="X-UA-Compatible" content="IE=6"><!-- IE6 mode -->
<meta http-equiv="X-UA-Compatible" content="IE=5"><!-- IE5 mode -->

特定版本的IE支持所要求的兼容性模式多于一种,如:
<meta http-equiv="X-UA-Compatible" content="IE=5; IE=8" />

Google Chrome Frame:
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
loading